PostgreSQL unter Windows 7 Pro 64bit

    • zenmaster
      zenmaster
      Bronze
      Dabei seit: 07.11.2007 Beiträge: 12
      Nabend,

      habe gerade Windows 7 Pro 64 installiert und festgestellt, dass der PostgreSQL Dienst nicht gestartet werden kann. Wenn ich den Task-Manager aufrufe wird mir der Dienst "pgsql-8.3" als Beendet angezeigt, wenn ich diesen dann starten will kommt die Fehlermeldung "Der Dienst konnte nicht gestartet werden: Der Vorgang konnte nicht beendet werden. Zugriff verweigert".
      Ich hatte schon bei der Installation ein paar Probleme die aber mit dem Starten im Kompatibilitätsmodus behoben wurden.

      Edit: wenn ich es über cmd versuche kommt die Meldung "Systemfehler 5 aufgetreten. Zugriff verweigert"

      Schon jemand eine Lösung für dieses Problem?

      Danke
  • 6 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.190
      Ich würde dir die Postgresql 8.4 empfehlen, die dürfte sich leichter installieren lassen.
    • hoff09
      hoff09
      Bronze
      Dabei seit: 20.10.2008 Beiträge: 566
      Hab mit PostgresSQL 8.4 unter Windows 7 64bit keine Probleme.
    • xsascha89x
      xsascha89x
      Bronze
      Dabei seit: 20.06.2007 Beiträge: 2.227
      Ich habe selbes Problem. Allerdings erst seit gestern. Vorher lief alles einwandfrei!

      Woran kann es liegen?

      Btw, du hast die Konsole nicht im Admin-Modus gestartet, denn dann käme folgendes: ;-)



      Prozess kann nicht gestartet werden, über keinen Weg. Doch wieso nun plötzlich? Vorher lief alles einwandfrei. Die einzige "Änderung" die ich in der zwischenzeit unternahm war, dass ich die Windows-Firewall ausgestellt habe, doch das dürfte doch keine Auswirkungen darauf haben? (Habe sie nun auch mal wieder ein / aus gestellt, ändert nichts)

      Wenn ich nun PG 8.4 installiere, findet er meine alten Datenbanken noch und ist es dazu kompatibel?

      Greetz.



      EDIT: Habe versucht PG 8.4 zu installiere, doch er nimmt das PW von meinem postgresql acc nicht an...
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.190
      Versuch mal die Datei postmaster.pid im data Verzeichnis zu löschen. Vielleicht lässt sich der Dienst dann wieder starten.
      Den Rechner hast du ja sicherlich schon mal neu gestartet oder?
    • SvenBe
      SvenBe
      HeadAdmin
      HeadAdmin
      Dabei seit: 19.04.2006 Beiträge: 13.468
      ich hab 8.4 auf windows7 installiert und funzt von anfang an
    • Eretico
      Eretico
      Bronze
      Dabei seit: 29.11.2007 Beiträge: 763
      Es kommt darauf an, welchen Namen der Dienst verwendet. Standardmäßig trägt der Dienst den Usernamen "postgres" als Nutzer des Dienstes ein. Elephant z.B. installiert postgres automatisch unter dem Benutzernamen "elephant" (was ich für unsinnig halte). Ein PostgreSQL-Update trägt aber wieder den Benutzernamen "postgres" für den Dienst ein.

      Wie kann ich das ändern? Systemsteuerung aufrufen und nach "Dienste" suchen, dann den Punkt "Lokale Dienste anzeigen" aufrufen. Dort suche ich nach dem Dienst "Postgres..." und rufe mit rechter Maustaste die Eigenschaften auf. Auf dem zweiten Karteireiter "Anmeldung" findet sich nun der User "postgres" eingetragen, den ich nun durch den User "elephant" ersetzen muss.