Probleme bei der Installation

    • spencer84
      spencer84
      Bronze
      Dabei seit: 28.09.2009 Beiträge: 101
      Bei der Installation bekam ich die Fehlermeldung das die "Prozedurale Sprache" nicht installiert werden konnte.
      Hatte mir da nichts bei gedacht und einfach auf ok geklickt. Nun wollte ich schauen ob ich eine Verbindung zur Datenbank bekomme, aber das klappt natürlich nicht.

      Ich hab dann mal den pgAdfmin III gestartet und da steht ja der Server drin. Nur ist der mit einem roten Kreuz makiert und ich kann keine Verbindung zu diesem herstellen. Bekomme die folgende Fehlermeldung:

      [QUOTE]
      Server doesn't listen
      The server doesn't accept connections: the connection library reports
      could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?
      If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly?
      For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first.
      For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'.
      You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective.
      If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community.
      [/Quote]

      Wenn ich unter Verwaltung die Dienste anschaue, läuft der PostgreSQL Dienst, daran kann es also nicht liegen.
      Der Server läuft auch unter der lokalen IP und der Port 5432 ist auch von der Firewall frei gegeben. Ich hab sie testweise auch ausgeschaltet, hat aber nichts am Ergebnis geändert. Das Problem muss also bei PostgreSQL liegen. Nur leider fehlt mir ein Ansatz, wie ich da anfangen könnte, da ich mit PostgreSQL noch keine Erfahrung habe. Habe bisher nur mit normalen MySQL Servern zu tun gehabt...will ja Postgres auch nur für den Holdem Manager haben :D

      Vielleicht hat ja von euch jemand eine Idee wo ich bei dem Problem nochmal ansetzen könnte!?
  • 6 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Starte den Dienst mal als Local System Account statt als Postgres (in den Windows Diensten einstellbar).

      Es wundert mich eigentlich das er überhaupt läuft nachdem der obige Fehler mit den prozeduralen Sprachen kam.

      Was für eine Firewall hast du im Einsatz?
      Hast du Postgresql schon vorher mal installiert gehabt?
    • spencer84
      spencer84
      Bronze
      Dabei seit: 28.09.2009 Beiträge: 101
      Original von netsrak
      Starte den Dienst mal als Local System Account statt als Postgres (in den Windows Diensten einstellbar).

      Es wundert mich eigentlich das er überhaupt läuft nachdem der obige Fehler mit den prozeduralen Sprachen kam.

      Was für eine Firewall hast du im Einsatz?
      Hast du Postgresql schon vorher mal installiert gehabt?
      Das starten als Local System Account hat nichts gebracht, immernoch die gleiche Fehlermeldung.

      Also hab die Firewall im Router und lokal halt Kaspersky. Hatte beide aber deaktiviert um sie als Fehlerquelle auszuschließen.

      Ich glaub eine alte Installation wird mein Problem sein. Hatte schon mal vor ein paar Monaten testweise versucht Postgres zu installieren. Hatte nun aber alles genau nach Anleitung deinstalliert und neu installiert. Aber alles ohne Erfolg. Habe aber auch die Vermutung das es eher daran liegen wird...
      Zum testen hab ich noch nen Virtuellen PC installiert. Dort ist quasi das gleiche Betriebssystem (Vista) installiert und dort lief der Holdem Manager inkl. Postgres gleich bei der ersten Installation. Die Grundeinstellung ist auf dem virtuellen PC exakt die gleiche.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Deinstallier nochmal komplett - Anleitung oben bei den wichtigen Links und installier Version 8.4.
    • spencer84
      spencer84
      Bronze
      Dabei seit: 28.09.2009 Beiträge: 101
      Ok, werd ich dann später machen. Muss erstmal ne Runde PingPong spielen :D
    • spencer84
      spencer84
      Bronze
      Dabei seit: 28.09.2009 Beiträge: 101
      Erstmal vielen Dank, PostgreSQL läuft nun, aber nun kommt das nächste Problem:

      "The following error occurred when trying to initialize the HM database : Fehler: 22023 neue Kodierung (SQL_ASCII) ist inkompatibl mit der Kodierung der Template Datenbank (UTF8)"
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Bitte die aktuelle Beta verwenden http://rvgsoftware.fileburst.com/HmBetaUpdate.exe und dann eine UTF Datenbank erstellen.