Postgres Dienst startet nicht mehr

    • TheTommyn
      TheTommyn
      Bronze
      Dabei seit: 03.02.2007 Beiträge: 797
      Hi Leute,

      Mein Postgres startet net mehr. Dadurch spuckt Holdemmanager immer folgende Fehlermeldung aus:

      The following error occurred when trying to open the database: Failed to establish a connection to '127.0.0.1'


      PgAdmin sagt dazu:

      Server doesn't listen
      The server doesn't accept connections: the connection library reports
      could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?
      If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly?
      For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first.
      For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'.
      You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective.
      If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community.



      Vorgeschichte:

      Ich habe heute versucht für die Uni ne VPN Verbindung zu errichten. Hab dies erstmal via Windows 7 versucht, ging net. Also die Verbindung wieder gelöscht und dann hab ich Shrew-VPN installiert, da ich Win 7 64bit installiert habe. Hab dann während der Installation nen Bluescreen bekommen. Danach hab ich es aber dennoch deinstalliieren können im abgesicherten Modus. Habs im abgesicherten Modus nochmal erneut sauber installiert, diesmal ohne Bluescreen, und dann nochmal sauber deinstalliert.

      Danach fing es an, dass mein Netzwerk bzw. Internet sich am Anfang nur noch ganz langsam aufbaut. Braucht so um die 5 min beim Systemstart. Danach funz Internet einwandfrei.

      Wollte dann ne runde pokern, und dann kam halt die Meldung von HM dass Postgres net mehr geht.

      Habe so gut es geht bei google gesucht. Konnte aber net viel finden.

      Was ich bisher gemahct habe:
      Postgres neu installiert. Dienst versucht per Hand zu starten. Geschaut ob die Benutzerkonten passen. Postgres hat aufjedenfall Rechte den Dienst zu starten. Hab Windows 7 auf gestern zurückgespielt.

      Ja das wars. Ich hoffe hier hat jemand nen Plan, was da aufn System passiert ist. Ich weiß es nicht.

      Bitte helft mir :D
  • 3 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Lies dir erstmal den Postgres Link in meiner Signatur durch - Troubleshooting.

      Vermutlich reicht es die Postmaster.pid zu löschen und den Rechner neu zu starten.
    • TheTommyn
      TheTommyn
      Bronze
      Dabei seit: 03.02.2007 Beiträge: 797
      Lol 2 1/2 Std selber rumgefuchtelt. Besser hätte ich sofort hier reingepostet. Gelöscht => Neustart => :D

      Inet connected auch wieder sofort, also hat sich das System beim booten wohl am Postgres aufgehängt, was alles bissel verzögert hat.

      Jetzt wäre es mega cool und wenn du in 1-2 Sätzen erklären kannst, was da jetzt schiefgelaufen ist? Hab echt nichts dazu im Internet gefunden :( :( .
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Wenn du an den Netzwerkeinstellungen rumgefummelt hast ist der Postgresql Dienst vermutlich abgestürzt.
      Bei so einem Absturz bleibt diese Lock Datei postmaster.pid stehen. Beim Neustart guckt der Dienst einfach ob es die Datei schon gibt und verweigert dann.