Windows 7 Installtionsprobleme

    • merkabah
      merkabah
      Silber
      Dabei seit: 03.08.2006 Beiträge: 703
      Habe auf meim neuen Laptop PokerTracker 2 installiert.

      Leider gibt es bei der Installtion von PostgreSQL 8.0.3 nur Probleme.

      Im Forum steht, daß mit PostgreSQL 8.4 keine Probleme entstehen.

      Jedoch steht in der PS-Anleitung zu PT2 daß man nur die Version
      8.0.3 verwenden soll.

      Ist das noch aktuell ?

      Danke für Eure Rückantworten.
  • 9 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      8.0.3 ist auf alle Fälle nicht aktuell, ob PT2 allerdings mit Postgresql 8.4 läuft kann ich dir nicht sagen.
      8.3.x geht aber auf alle Fälle.
    • merkabah
      merkabah
      Silber
      Dabei seit: 03.08.2006 Beiträge: 703
      Danke für Deine prompte Rückantwort.

      Habe nun PostgreSQL 8.3.x installiert. Funktionierte ohne Probleme

      Wo (über den Stackbuilder ?) und welche Einstellungen muß ich nun vornehmen?

      Bei Pokertracker 2 unter "PostgreSql Database Funnciton" erhalte
      ich dei Fehlermeldung "999 - SQLSTATE = IM002

      Finde leider keine bebilderte Installationsanleitung.

      Danke im voraus
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Da kann ich dir leider nicht weiterhelfen da ich schon seit Jahren kein PT2 mehr einsetze. Falls Ajezz hier nichts dazu sagt poste mal im Pokertrackerbereich oder verschieb den Thread dahin.
    • merkabah
      merkabah
      Silber
      Dabei seit: 03.08.2006 Beiträge: 703
      Nachdem ich festgestellt habe, daß PT2 ab nächstem Jahr nicht mehr
      supported wird, hab ich mich entschoßen den Elephant zu installieren.

      Habe zuvor das Postgresql gem. Anleitun deinstalliert.

      Elephant 0.69 hat funktioniert. Beim installieren von PostgreSQl
      gab es leider wieder Probleme:

      Folgende Meldung:

      Es konnte keine Verbindung zum Datenbakserver
      aufgebaut werden!

      Erweiterte Information:

      Failed to estabhlis a connection to '127.0.0.1'

      Hab wie im Forum beschrieben
      [Guide] Datenbank Probleme
      die Fehlermeldung abgearbeitet.

      Hier steht:
      Achtung:
      Kann der Dienst nicht gestartet werden deutet das daraufhin, dass die Datenbank nicht (korrekt) installiert wurde.
      Im Elephant Odner muss dann die Datei "postgresql-8.3.msi" ausgeführt und installiert werden


      Nachdem Postgresql nicht startet wollte ich wie beschrieben das Programm
      manuell installieren.

      Dann kamen diese Meldung

      ---------------------------
      Account error
      ---------------------------
      User 'EDDIE-PC\postgres' was not found. Would you like the account to be created for you?
      ---------------------------
      Ja Nein
      ---------------------------

      bin auf ja gegangen.

      Danach kam späte diese Meldung:

      ---------------------------
      Data directory error
      ---------------------------
      The specified data directory is not empty.

      If you have an existing database with the same major version number, you do not need to initialise a database cluster.
      If you have an existing database with a different major version you need to backup your old database and create a new one.
      ---------------------------
      OK
      ---------------------------


      Die Installation wurde abgebrochen.

      Kann PostgreSQL nicht deinstallieren, da es unter Software nicht
      aufscheint.

      PS: Habe auch alles als Admin ausgeführt.

      System: Windows 7 Professional
      Elephant 0.69

      Wie bringe ich Elephant zum Laufen?

      Danke für Eure Hilfe
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Es gibt bereits ein Postgresql Data Verzeichnis von deiner alten Installation. Dieses musst du vor der Installation löschen.
    • merkabah
      merkabah
      Silber
      Dabei seit: 03.08.2006 Beiträge: 703
      Ich glaube nicht, daß dann das Problem gelöst ist. ?(

      Bei der ersten Installation war ja noch gar kein Postgresql
      installiert.

      Wie bekomme ich eine Verbindung zum Datenbankserver unter
      Windows 7 ?
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Original von merkabah
      Ich glaube nicht, daß dann das Problem gelöst ist. ?(

      Bei der ersten Installation war ja noch gar kein Postgresql
      installiert.

      Wie bekomme ich eine Verbindung zum Datenbankserver unter
      Windows 7 ?
      Hey merkabah,

      unter Win 7 verhält es sich im Prinzip gleich wie unter Win Xp oder Windows Vista.

      Ich würde vorschlagen, du deinstallierst nochmal alles was mit Datenbanken oder dem Elephant zu tun hat und fängst von vorne an.

      PostgreSQL musst du wohl manuell löschen, d.h. alle Ordner die von PostgreSQL existieren.
    • merkabah
      merkabah
      Silber
      Dabei seit: 03.08.2006 Beiträge: 703
      Danke für Eure Hilfe.

      Habe Windows 7 neu aufgesetzt, und siehe da alles
      funktioniert ohne Probleme.

      Hab höchstwahrscheinlich selbst was verstellt. ?(
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Mag sein, Hauptsache jetzt funktioniert alles :]