Kann nicht zu PostgreSQL verbinden

    • Steffen85
      Steffen85
      Bronze
      Dabei seit: 13.10.2007 Beiträge: 198
      Habe ein Problem, weder der HM noch PGadmin können zu PostgreSQL verbinden.

      Bei PGadmin steht unten links "Connecting zu database... Failed."

      Beim HM sagt er "A connection to PostgreSQL could not be made. Would you like to have Holdem Manager attempt to start the service?". Hab dann nochma versucht auf connect zu klicken, dann kam das:

  • 9 Antworten
    • ozoz20
      ozoz20
      Bronze
      Dabei seit: 25.01.2006 Beiträge: 173
      Habe so ein ähnliches Problem. Die Verbindung zum HM wird auch nicht hergestellt. Ich muss, bevor ich den HM starte, einmal den Dienst neu starten. Dann läuft auch der HM.

      Da ich mich daran gewöhnt habe, suche ich auch nicht weiter nach dem Fehler. So funktioniert es jedenfalls bei mir.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.831
      Erstmal prüfen ob der Postgresql Dienst läuft oder sich starten lässt. Manchmal wirkt auch ein Neustart des Rechners Wunder.
      Oder mal die versteckte Datei Postmaster.pid im postgresql\data Verzeichnis löschen sofern vorhanden.
      Firewalls sind auch beliebte Postgresql Killer.

      Der Postgresql Link in meiner Signatur liefert im Troubleshooting auch einige Hinweise.
    • Steffen85
      Steffen85
      Bronze
      Dabei seit: 13.10.2007 Beiträge: 198
      Dienst lässt sich nicht starten, Rechnerneustart hat nichts genutzt, Postmaster.pid ist nicht vorhanden, Firewall hab ich schon deaktiviert.
      In deiner Signatur steht was von den logfiles. In der letzen steht jetzt das hier drin:

      2009-12-09 23:37:53 CET LOG: database system was interrupted while in recovery at 2009-12-09 23:21:59 CET
      2009-12-09 23:37:53 CET HINT: This probably means that some data is corrupted and you will have to use the last backup for recovery.
      2009-12-09 23:37:53 CET LOG: database system was not properly shut down; automatic recovery in progress
      2009-12-09 23:37:53 CET LOG: redo starts at AC/7900F358
      2009-12-09 23:37:53 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:37:53 CET FATAL: the database system is starting up
      2009-12-09 23:37:54 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:37:54 CET FATAL: the database system is starting up
      2009-12-09 23:37:55 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:37:55 CET FATAL: the database system is starting up
      2009-12-09 23:37:56 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:37:56 CET FATAL: the database system is starting up
      2009-12-09 23:37:57 CET LOG: could not open file "pg_xlog/00000001000000AC0000007E" (log file 172, segment 126): No such file or directory
      2009-12-09 23:37:58 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:37:58 CET FATAL: the database system is starting up
      2009-12-09 23:37:59 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:37:59 CET FATAL: the database system is starting up
      2009-12-09 23:38:00 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:38:00 CET FATAL: the database system is starting up
      2009-12-09 23:38:01 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:38:01 CET FATAL: the database system is starting up
      2009-12-09 23:38:02 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-12-09 23:38:02 CET FATAL: the database system is starting up
      2009-12-09 23:38:02 CET LOG: startup process (PID 5448) was terminated by exception 0xC000000D
      2009-12-09 23:38:02 CET HINT: See C include file "ntstatus.h" for a description of the hexadecimal value.
      2009-12-09 23:38:02 CET LOG: aborting startup due to startup process failure


      Kann damit aber nichts einfangen.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.831
      Was für eine Firewall?
    • Steffen85
      Steffen85
      Bronze
      Dabei seit: 13.10.2007 Beiträge: 198
      Windows :D


      Hab jetzt HM und PostgreSQL de- und wieder installiert, immernoch der selbe Fehler :(
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.831
      Das sind nicht die "normalen" Postgresql Probleme. Bei dir ist irgendwas anderes kaputt.

      Versuch doch mal Google mit dem oberen Fehler.

      Oder du versuchst mal diese Postgresql Version: http://rvgsoftware.fileburst.com/pginstaller.exe
    • Steffen85
      Steffen85
      Bronze
      Dabei seit: 13.10.2007 Beiträge: 198
      OK hab die Version aus deinem Link installiert, HM startet auch wieder. Aber wie bekomm ich da jetzt meine alte Datenbank wieder rein? Kann ich einfach den data Ordner überschreiben?

      Edit: Seh grad, dass der das auf der falschen Partition installiert, wie kann man das ändern?
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.831
      1. du kannst das alte data Verzeichnis nicht einfach rüberkopieren
      2. im Postgresql Link in meiner Signatur ist eine Anleitung zum verschieben des data Verzeichnisses
    • Steffen85
      Steffen85
      Bronze
      Dabei seit: 13.10.2007 Beiträge: 198
      Ok danke für deine Hilfe. HM läuft wieder, allerdings is meine alte Datenbank jetzt weg. Zum Glück hab ich noch ein paar HHs.