8.4 installiert, 8.2 backups wollen sich nicht restoren lassen

    • emrah999
      emrah999
      Black
      Dabei seit: 29.03.2006 Beiträge: 3.873
      habe hier 2 DB backups von 8.2 DBs, habe rechner neu aufgesetzt und dabei gleich 8.4 installiert.
      nu kriege ich die DBs nicht restored, was muss ich da machen?
      muss ich 8.2 reinstallieren, die hände exportieren und dann wieder einlesen?
      geht dass auch ohne dass ich PT2 wieder installiere?

      bitte helft mir, bin totaler noob in der hinsicht und total unvorbereitet drauf los gemacht :(
  • 11 Antworten
    • superpit
      superpit
      Silber
      Dabei seit: 27.05.2006 Beiträge: 1.941
      Original von emrah999
      habe hier 2 DB backups von 8.2 DBs, habe rechner neu aufgesetzt und dabei gleich 8.4 installiert.
      nu kriege ich die DBs nicht restored, was muss ich da machen?
      muss ich 8.2 reinstallieren, die hände exportieren und dann wieder einlesen?
      geht dass auch ohne dass ich PT2 wieder installiere?

      bitte helft mir, bin totaler noob in der hinsicht und total unvorbereitet drauf los gemacht :(
      geht nicht V8.2 benutzt das alte ASCII-Format und die Version 8.4 das UTF. Du kannst keine Ascii-Backup unter 8.4 wieder herstellen. Die einziges Möglichkeit ist unter 8.2 die Haende mit PT2 zu expotireren und dann mit 8.4 wieder zu importieren.

      pit
    • emrah999
      emrah999
      Black
      Dabei seit: 29.03.2006 Beiträge: 3.873
      na super X(

      vielen Dank erstmal für deine Hilfe
    • Wills
      Wills
      Global
      Dabei seit: 13.08.2006 Beiträge: 8.773
      hm gut, dass ich den thread hier gleich gefunden habe

      will grad nach einigen monaten abstinenz wieder HEM installieren, mein backup ist mit 8.2 gemacht (unter dos)

      hab die alte postgres .exe auch noch, also generell kein problem

      nun meine frage, ob ein exportieren der hände+neu aufsetzen von postgres sinn macht...hab auf der postgres seite gelesen, dass es 300 neue features gibt, aber am wichtigsten ist für uns normalo poker-db user ja die geschwindigkeit/stabilität beim importieren
      gibts da krasse unterschiede?

      danke
    • Wills
      Wills
      Global
      Dabei seit: 13.08.2006 Beiträge: 8.773
      ok nochwas

      bei der installation von postgres, kam grad folgender fehler: "Konnte nicht mit dem Test-Netzwerk-Socket verbinden: 10013"

      ich habe win7 seit paar monaten und hatte darauf noch kein postgres bzw hem

      habe auch an der domäne o.ä. nix geändert

      wenn ich den port allerdings von 5432 einfach mal auf 5433 ändere geht es, kann mir das jemand erklären? was hat das für konsequenzen?

      /edit

      und wie erkenn ich eigentlich, ob hem mit postgres arbeitet? früher musste man das doch mMn beim start von hem auswählen, sowas kam grad gar nicht. also ich weiß nicht obs daran lag, dass ich erst hem und dann postgres installiert habe ?(


      danke im voraus
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.820
      Wenn du die Vollversion von Postgresql installiert hast ist da ein Postgresql 8.4 mit drin. Das läuft dann auf Port 5432.
      Darum konntest du 8.2 nicht auf dem Port installieren und musstest 5433 nehmen. Du hast jetzt also vermutlich 2 Postgresql Versionen parallel laufen.

      Ich würde dir empfehlen, die Hände in die neue HEM Datenbank unter Postgresql 8.4 zu importieren.
    • Wills
      Wills
      Global
      Dabei seit: 13.08.2006 Beiträge: 8.773
      Du hast recht, tatsächlich laufen 2 Dienste!

      Ich habe zuerst HEM und dann postgres 8.2 - und unbewusst 8.4 und zwar bei der Installation vom HEM wie ich grad merke - installiert. Anscheinend hat postgres nun automatisch eine db mit dem standard-pw 'postgrespass' auf port 5432 erstellt. Ich konnte nämlich schon Hände importieren.

      Beim Importieren meiner db hab ich jetzt trotzdem Probleme, egal ob unter 8.2 oder 8.4. Ich habe deshalb jetzt 8.2 deinstalliert (mit der Anleitung, trotzdem bleibt der Ordner wo es installiert war mit ~33mb 'data' gefüllt).
      Trotzdem bekomme ich Probleme bei der Wiederherstellung meiner db.
      Wäre nett, wenn du dir das mal ansehen könntest netsrak, die Anleitung im geöffneten editor benutz ich immer zum erstellen des backups.



      In DOS wird einiges angezeigt, dann hängt es sich aber scheinbar auf, also es steht bei 'ALTER TABLE' mit blinkendem cursor aber nix passiert, DOS lässt sich aber noch problemlos schließen, die db is natürlich 0 hände groß.

      Sollte ich nochmal komplett postgres (also auch 8.2) und HEM deinstallieren? Oder woran liegt das ?(

      Das Problem was jedes mal kam ist halt: 'role "postgres" already exists'
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.820
      Ich verstehe dein Problem jetzt nicht. Du kannst keine 8.2 Datenbank in 8.4 restaurieren.

      Du musst die Hände neu importieren.
    • Wills
      Wills
      Global
      Dabei seit: 13.08.2006 Beiträge: 8.773
      danke für deine antwort

      ich dachte das ja genauso, war bloß durch deinen folgenden satz verwundert (du hast vielleicht überlesen, dass ich oben schon geschrieben hab, dass mein backup unter 8.2 gemacht wurde)

      Original von netsrak
      Ich würde dir empfehlen, die Hände in die neue HEM Datenbank unter Postgresql 8.4 zu importieren.
      also es ging ja auch nicht unter 8.2 wo ich vorhin noch beide versionen drauf hatte...naja ich werd demnächst komplett postgres+HEM runtermachen und dann nochmal mit 8.2 versuchen

      noch ne frage dazu: wie erkenne ich denn, ob wirklich alles gelöscht wurde mit dieser deinst-exe? wie gesagt ist der ordner noch da mit dem unterordner data.

      mfg
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.820
      Das data Verzeichnis wird bei der Deinstallation aus Sicherheitsgründen nicht mitgelöscht, das musst du von Hand löschen.

      In den Windows Diensten sollte nur noch ein Postgresql Dienst erscheinen.
    • Wills
      Wills
      Global
      Dabei seit: 13.08.2006 Beiträge: 8.773
      ok, ich hab jetzt beide dienste deinstalliert (und hem)

      jetzt will ich only 8.2 draufmachen:

      1. muss ich bei der dienste-konfiguration das pw: postgres angeben, obwohl ich dachte das pw könnte man jetzt frei wählen

      2. beim db-cluster (wo man ja auch beliebiges pw eingeben können sollte) kommt bei mir folgende fehlermeldung:

      "Der 'Secondary Logon' Dienst läuft nicht. Dieser Dienst ist zum Initialisieren der DB erforderlich. Bitte diesen Dienst starten und nochmal versuchen."
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.820
      1. Da es den Benutzer postgres noch gibt musst du das gleiche Passwort wie vorher verwenden (vermutlich postgrespass). Oder du löscht den Benutzer in der Kommandozeile:
      net user postgres /delete
      dann kannst du bei der Installation ein beliebiges neues Passwort vergeben.

      2. Das ist ein Standards Windows Dienst den du genau bei diesen Diensten starten musst. Näheres z.B. über Google