[DONE] Maschinencode wird nicht angezeigt

    • MKR
      MKR
      Silber
      Dabei seit: 24.04.2005 Beiträge: 496
      Seit ein paar Tagen hat mein Elephant nur mehr eingeschränkte Funktionalität. Ich kann aber keinen Lizenzcode erstellen, weil:
      Mir wird kein Maschinencode angezeigt, sondern nur ein ? an entsprechender Stelle. Neuinstallationen haben nichts gebracht.
      Elephant v.0.69, PostgeSQL 8.3, Vista 32 bit
      Ja, ich starte ihn mit Administratorrechten.
      Ja, ich hab wirklich schon verschiedenste "Dinge" ausprobiert (z.B. Installation der 0.72 v., die mir dann aber schon beim Start abgestürzt ist).
      Ja, den Thread gibts schon im Elephant-Forum, der Ticket-Support hat mich aber auf das Beta Forum verwiesen.

      Die einzige "Lösung", die mir noch einfällt ist, dass ich den Elephant zuerst komplett deinstallieren müsste (inklusive aller Infos, seit wann er installiert ist [also Registry und allen drum und dran]), was aber wahrscheinlich aus lizenzrechtlichen Gründen nicht möglich ist, und ich ja auch nicht genau weiß, wo er sich überall eingenistet hat.

      Es ist echt ein bisschen tough NL SH ohne Zahlenwerte-HUD zu spielen, deshalb bin ich für jeden Lösungsvorschlag sehr dankbar.
  • 9 Antworten
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hallo MKR,

      im Grunde würde ich in so einem Fall einfach den Elephant über die Systemsteuerung deinstallieren und neu installieren. Da du das aber schon gemacht hast, werde ich mal nachfragen was du noch versuchen kannst.
    • MKR
      MKR
      Silber
      Dabei seit: 24.04.2005 Beiträge: 496
      Hallo mrk1988,
      danke dir, dass du da mal nachfragst.
      Ich habe heute mal 3 Stunden wieder so alles Mögliche probiert (mit dem Endergebnis, das ich meine Datenbank abgeschossen habe, was aber jetzt kein schlimmes Problem war, da ich die Handhistory extra gesichert hatte, und derzeit sowieso mit den Daten nicht viel anfangen kann).

      Auf jeden Fall hab ich wieder mal den Elephant deinstalliert, und bin dann auf Deep-Search-Modus umgestiegen, und habe auch alles gelöscht, was annähernd nur nach Elefanten gerochen hat (Versteckte Ordner, Registry...). Danach Neuinstallation, aber er wusste nach wie vor, dass er im Trial lief, und zeigte immer noch keinen Maschinencode an (Kompliment, da habt ihr euch gut in meinem System versteckt ;-) ).

      Ich weiß echt nicht weiter, das Einzige, das ich noch nicht versucht habe, ist eine ältere Version zu installieren, aber das kommt wahrscheinlich eh aufs Gleiche?
    • MKR
      MKR
      Silber
      Dabei seit: 24.04.2005 Beiträge: 496
      Ich bring mal ein Update meiner Verzweiflung:

      Nachdem ich ja meine Datenbank abgeschossen hatte, habe ich alles einwandfrei und sauber deinstalliert. Ich hab dann gleich die Gelegenheit dazu genützt, um PostgeSQL auf 8.4 upzudaten (bzw. neu zu installieren).
      Dann hab ich nochmals die gesamte Palette ausbrobiert: Zuerst Ele 0.67 (ältere Version) installiert = gleiches Ergebnis. Dann die neue 0.73 version versucht (die scheint aber nicht sonderlich Vista-tauglich zu sein, wie schon die 0.72, da sie mir schon beim Start abstürzt). Dann wieder zur "offiziellen" 0.69 Version.
      Well, alles wie gehabt, wenigstens hab ich nun die neuere Datenbank ;(

      Gibts keine "Die-hat-der-Arme-aber-redlich-verdient-Lizenz", für die man keinen Maschinencode braucht? :f_love:
    • MKR
      MKR
      Silber
      Dabei seit: 24.04.2005 Beiträge: 496
      Vielleicht hilft das weiter, die Ausnahmen erhalte ich beim Ausstieg von Elephant. Man beachte insbesondes die letzte Zeile!

      OS: Microsoft Windows NT 6.0.6002 Service Pack 2
      .NET Runtime: 2.0.50727.4200
      RAM: 0GB
      Processors: 4
      CPU:
      Software version: 0.69

      (10) Log: 11:43:34.65 -- , line 0: System.TypeInitializationException: Der Typeninitialisierer für "System.Management.ManagementPath" hat eine Ausnahme verursacht. ---> System.TypeInitializationException: Der Typeninitialisierer für "System.Management.MTAHelper" hat eine Ausnahme verursacht. ---> System.Runtime.InteropServices.COMException (0x80040154): Die COM-Klassenfactory für die Komponente mit CLSID {A8F03BE3-EDB7-4972-821F-AF6F8EA34884} konnte aufgrund des folgenden Fehlers nicht abgerufen werden: 80040154.
      bei System.Management.MTAHelper..cctor()
      --- Ende der internen Ausnahmestapelüberwachung ---
      bei System.Management.MTAHelper.CreateInMTA(Type type)
      bei System.Management.ManagementPath.CreateWbemPath(String path)
      bei System.Management.ManagementPath..ctor(String path)
      bei System.Management.ManagementPath..cctor()
      --- Ende der internen Ausnahmestapelüberwachung ---
      bei System.Management.ManagementScope._Clone(ManagementScope scope, IdentifierChangedEventHandler handler)
      bei System.Management.ManagementObjectSearcher..ctor(ManagementScope scope, ObjectQuery query, EnumerationOptions options)
      bei System.Management.ManagementObjectSearcher..ctor(String queryString)
      bei PBN.Licensing.GetWindowsID()
      bei PBN.Licensing.GenerateMachineCode()
      (10) , line 0: System.TypeInitializationException: Der Typeninitialisierer für "System.Management.ManagementPath" hat eine Ausnahme verursacht. ---> System.TypeInitializationException: Der Typeninitialisierer für "System.Management.MTAHelper" hat eine Ausnahme verursacht. ---> System.Runtime.InteropServices.COMException (0x80040154): Die COM-Klassenfactory für die Komponente mit CLSID {A8F03BE3-EDB7-4972-821F-AF6F8EA34884} konnte aufgrund des folgenden Fehlers nicht abgerufen werden: 80040154.
      bei System.Management.MTAHelper..cctor()
      --- Ende der internen Ausnahmestapelüberwachung ---
      bei System.Management.MTAHelper.CreateInMTA(Type type)
      bei System.Management.ManagementPath.CreateWbemPath(String path)
      bei System.Management.ManagementPath..ctor(String path)
      bei System.Management.ManagementPath..cctor()
      --- Ende der internen Ausnahmestapelüberwachung ---
      bei System.Management.ManagementScope._Clone(ManagementScope scope, IdentifierChangedEventHandler handler)
      bei System.Management.ManagementObjectSearcher..ctor(ManagementScope scope, ObjectQuery query, EnumerationOptions options)
      bei System.Management.ManagementObjectSearcher..ctor(String queryString)
      bei PBN.Licensing.GetWindowsID()
      bei PBN.Licensing.GenerateMachineCode()
    • MichaelWagner42
      MichaelWagner42
      Bronze
      Dabei seit: 12.09.2009 Beiträge: 1.552
      Hallo,

      Ich habe zu Deiner Fehlermeldung mal etwas geforscht: Da scheint mit Deinem .NET etwas nicht in Ordnung zu sein.

      Dieser Teil der Lizenzgenerierung wird allerdings mit der 75er Version nicht mehr benötigt - Wenn Du also noch bis zum Ende unseres Sprints warten kannst, dann kannst Du Dir auch in gut drei Wochen diese Version vom Developerblog holen.

      Falls Du nicht so lange warten wills, schreibe mir bitte über das Communitymodul eine PN.

      Danke
      Michael
    • MKR
      MKR
      Silber
      Dabei seit: 24.04.2005 Beiträge: 496
      Servus Michael,
      also 3 Wochen kann ich locker warten, ich spiele derzeit eh "nur" NL25, und da tuns solange die Anfängerstats.
      Das sind erfreuliche Nachrichten, da ich mir schon überlegte den Holdem Manager zu kaufen, mir der Elephant mit seinen Funktionen aber komplett ausreicht.
      Zwischenzeitlich werde ich vielleicht auch mal das .NET-Framework 3.5SP1 neu installieren, wenn ich die Muse dazu habe (und eventuell auch mein Windows SDK, falls das irgendwie "dazwischenpfuscht").

      Viele Dank für deine Antwort!
      (Falls ich dann mit der .75er ein Problem habe, kann ich dich ja immer noch über das Communitymodul "belästigen" :tongue: ).
    • goxie
      goxie
      Bronze
      Dabei seit: 04.10.2008 Beiträge: 4.456
      Bei mir besteht das selbe Problem. Habe ich auch schon in einem älteren Thread geschreben. Leider gibt es immer noch keine Lösungsvorschläge dazu X(
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Siehe Michaels Post weiter oben ;)
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Update: Version 0.75 ist erschienen. Falls es noch Probleme gibt, bitte einen neuen Thread eröffnen. Denkt bitte auch an unsere Guidline für das erstellen neuer Threads:

      [Guide] Erstellen von Fehler- und Support-Anfragen