Excel - formel für anzahl

    • bernie0303
      bernie0303
      Bronze
      Dabei seit: 30.09.2008 Beiträge: 3.486
      kenn mich in excel zwar ganz passabel aus, aber hier streikt irgendwie meine logik:

      in der spalte stehen verschiedene elemente, zusammengesetzt aus 2-4 zahlen sowie 1-2 buchstaben.
      gesamt gibt es 26 buchstabenkombinationen.
      ich brauch eine statistik, wie oft welche kombination vorkommt.


      beispiel:
      1234 AA
      415 B
      746 AA

      als ergebnis sollte das dann so ausschauen:
      code:
      Spalte A    Spalte B
      AA:             2
      B:              1

      Spalte B sollte hierbei als formel ausgegeben werden.

      ich könnte es manuel durchzählen, würd aber aufgrund der datenmenge zu möglichen fehler führen.


      ich denke ich könnts irgendwie mit verknüpfen von diversen formeln rausbringen (WENN, ANZAHL, ...), aber das müsste doch auch einfacher gehen?
      konnte leider keine passende funktion finden, werd aber weiter suchen.
  • 6 Antworten
    • WFaber
      WFaber
      Bronze
      Dabei seit: 05.06.2007 Beiträge: 88
      Du kannst die Frequency Funktion benutzen. Hab allerdings keine Ahnung wie die in der dt. Version heißt, ws was mit Frequenz oder Häufigkeit.

      Achte auch darauf, dass es sich um eine Array Formel handelt, das heißt du musst erst ALLE Zellen markieren in denen später die Formel stehen soll (in deinem Beispiel in Spalte B), dann schreibst du
      =FREQUENCY(
      und wählst als ersten Parameter die Zellen wo deine Daten drin sind. Als zweiten Parameter dann deine Spalte A.
      Die Klammer schließen, und dann ganz wichtig, nicht ENTER, sondern STRG + SHIFT + ENTER drücken.

      Viel Spaß
    • larseda
      larseda
      Bronze
      Dabei seit: 06.08.2006 Beiträge: 9.299
      SUMIF sollte dafür gut gehen
      damit hab ich mal ne wareneingangsliste ausgelesen ^^

      SUMIF('1'!$B$1:$B$998;$B$1&""&"-"&""&$A16;'1'!D$1:D $998)
      so sah das dann aus ?(
    • WFaber
      WFaber
      Bronze
      Dabei seit: 05.06.2007 Beiträge: 88
      Hm mit SUMIF wüsste ich jetzt nicht wie das gehen sollte... wir haben ja Text, keine Zahlen!

      Ich seh auch gerade, dass FREQUENCY damit scheinbar auch Probleme hat... Da ist es wahrscheinlich einfacher, wenn du COUNTIF benutzt, also ANZAHLWENN (oder so?).

      In Zelle Bx einfach:
      =ANZAHLWENN($Daten; Ax)
      Dann runterziehen, fertig.
    • buccaneers
      buccaneers
      Bronze
      Dabei seit: 13.04.2006 Beiträge: 3.033
      Wenn ich das richtig verstanden habe, hast du eine Liste

      1234 AA
      255 AB
      1993 AA
      2994 CF
      229 AA
      ...

      Jetzt willst du schauen, wie oft z.B. die AA Kombi auftaucht?

      =ZÄHLENWENN(markierter Bereich,"*****AA")

      Oder hab ich deine Frage missverstanden.
    • bernie0303
      bernie0303
      Bronze
      Dabei seit: 30.09.2008 Beiträge: 3.486
      argh. is doch ned so einfach, wenn man selbst was wichtiges vergisst :f_frown:

      also: buccaneers hast scho recht so.

      problem is, wie schon erwähnt, ich hab was vergessen ... es gibt eine weitere spalte für die zuständigkeit (2 möglichkeiten). ds sieht dann so aus:

      code:
      1234   AA    P1
      157    VV   P1
      8954   AA   P2
      375    VV   P2
      786    PP   P1
      111    AA   P1


      zuerst brauch ich die anzahl der zuständigkeiten von P2, danach die anzahl von P1 nach den buchstabenkombinationen (ohne die, die von P2 bearbeitet werden).

      also:
      P2: 2 edit: die hab ich scho, mit der zählenwenn funktion
      AA: 2 (zusätndigkeit P1)
      VV: 1 (zuständig P1)
      PP: 1 (zuständig P1)

      müsste dann mit =zählenwenn((*bereich*, "*****AA")UND(*bereich*=P1)
      funktioniere? ich versuchs mal.

      aber schonmal vielen dank für die formel. die hab ich gestern offensichtlich übersehen.


      ich habs \o/

      =SUMMENPRODUKT((A1:A20="AA")*(C1: C20="P1"))
    • DrOhnE84
      DrOhnE84
      Bronze
      Dabei seit: 22.08.2006 Beiträge: 957
      Warum nicht einfach ne Pivot Tabelle?