Connection zu Database failed ???

    • ChrisKo86
      ChrisKo86
      Bronze
      Dabei seit: 10.06.2007 Beiträge: 162
      Halli Hallo, ihr Pokerstrategen ...

      bis grade eben lief mein Elephant noch einwandfrei, danach schalte ich meinen PC aus und starte ihn 20min später wieder.
      Meine Freundin hat innerhalb der 20min einmal kurz angeschaltet und dann hardresettet (also auf den Power-Knopf gedrückt und festgehalten) - könnte ja iwie wichtig sein.

      Ich will ganz normal den Elephant spielen um den frisch durchgelesenen Content umzusetzten doch beim starten zeigt er mit 2x hintereinander folgende Fehlermeldung an:

      Fehlermeldung
      Connection to database NOT successful!
      Please ensure that PostgreSQL is running
      and your settings are correct.
      Diese Nachricht kann man mit "ok" weggklicken und der Elephant staten daraufhin.


      Dann sind alle meine Hände weg und wenn ich im Register Handhistory meine Hände neu laden möchte, dann stürzt mir er Elephant ab.
      Unter "Database Management" ist keine "known database" angegeben. Ich habe nur die Möglichkeit, eine neue zu erstellen.
      Bitte sagt mir, dass ich meine Hände noch habe ...

      Sonstiges
      PC: Asus F5SRseries
      CPU: Pent. T3200
      HDD: 320 GB
      RAM: 3GB
      Graphic: ATI mobility Radeon HD 3470; VRAM 512MB

      Pokeranbieter: PartyPoker
      Betriebssystem: Windows Vista
      mlg
      ChrisKo
  • 4 Antworten
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hallo CrhsiKo86,

      schau mal in der Systemsteuerung unter Verwaltung -> Dienste ob der postgreSQL Dienst läuft bzw. gestartet ist. Falls nicht, starte ihn mal manuell.

      Ich bin mir ziemlich sicher, dass deine Daten noch alle vorhanden sind. Erstelle mal eine neue Datenbank die gleich heißt wie die alte.
    • ChrisKo86
      ChrisKo86
      Bronze
      Dabei seit: 10.06.2007 Beiträge: 162
      hey mrk1988,

      dank dir schonmal für deine Antwort.

      folgendes passierte:
      Beim erstellen der neuen Datenbank war meine alte noch in der Liste angegeben.
      Beim verlassen des Fenstern er schien wieder die Fehlermeldung, dass die Verbindung zur Datenbank nicht erfolgreich war.

      Beim schließen des Elephants kamm dann folgende Meldung;
      Meldung beim Schließen des Elephant
      OS: Microsoft Windows NT 6.0.6001 Service Pack 1
      .NET Runtime: 2.0.50727.3603
      RAM: 3GB
      Processors: 2
      CPU: x64 Family 6 Model 15 Stepping 13: 9/64/185, 2000

      Software version: 0.69

      (10) Log: 18:37:38.24 -- Logfile set: C:\Users\ChrisKo\AppData\Local\PokerStrategy\Elephant\log.txt
      (10) Log: 18:37:38.25 -- Logfile cleared: C:\Users\ChrisKo\AppData\Local\PokerStrategy\Elephant\log.txt
      (10) Log: 18:38:49.46 -- , line 0: System.NullReferenceException: Object reference not set to an instance of an object.
      at PokerStrategyElephant.Database.IO.ExportFullHH(String path)
      (10) , line 0: System.NullReferenceException: Object reference not set to an instance of an object.
      at PokerStrategyElephant.Database.IO.ExportFullHH(String path)
      Als nächstes habe ich versucht den Dienst zu starten.
      Erst hab ich mit "msconfig" den Dienst gesucht und dieser war als "stopped" markiert.

      Danach bin deiner Anleitung gefolgt und habe versucht den Dienst manuell zu starten. Nach 3 Versuchen MIT und OHNE angeschalteten Elephant kam jedes mal folgende Fehlermeldung:
      Fehlermeldung bei der Dienstaktivierung
      Windows could not start the PostgreSQL Database Server 8.3 service on Local Computer.

      Error 1053: The service did not respond to the start or control request in a timely fashion.

      Ich befürchte ich muss PostgreSQL neu installieren, allerdings weiß ich nicht, wie ich meine jetztige Datenbank sichern könnte. (Ich weiß erstens nicht, welchen Pfad diese hat und hab das bis dato auch noch nicht herrausgefunden und zweitens weiß ich nicht, wie ich die nach der Neuinstallation von PostgreSQL wieder einbinden kann.
      Außerdem mach ich mal besser nichts, ohne das man mir das sagt ;)

      bin nicht so der Könner was PC's angeht. Maximal User.

      Ach so ... und mein Vista läuft auf English, deswegen kann ich leider keine Fehlermeldungstexte auf Deutsch posten.


      Aber immerhin ist die Datenbank noch nit weg. Jetzt muss nur noch der Dienst wieder laufen .... hoffe das schaffen wir (du) :-D


      mlg
      ChrisKo86
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hi,

      danke für den ausführlichen Bericht. Ich werde mal schauen was man da machen kann. Ich kontaktiere dich ;)
    • ChrisKo86
      ChrisKo86
      Bronze
      Dabei seit: 10.06.2007 Beiträge: 162
      UPDATE:


      Hmm... nachdem ich Vista (eigendlich wegen eines anderen Problems) mal die Selbstreparatur habe ausführen lassen, ist das Problem gelößt. :) :) :)

      Alle Daten noch da und endlich kann das große Ziel NL10 angegangen werden (Ja es darf gelacht werden, ich komm damit psychisch klar :-P)

      danke dir @ mrk1988 trotzdem für deine Hilfe und deine Mühen.

      mlg
      ChrisKo86