PostGre installiert sich nicht selbständig

    • xHexerx
      xHexerx
      Bronze
      Dabei seit: 22.02.2008 Beiträge: 294
      Hallo an alle,

      seit Monaten ärgere ich mich jetzt mit PostGre rum, weil ich es einfach nicht zum laufen bringe. X(

      Immer wenn ich den Elephant (als Admin, weil Vista) starten will, bekomme ich die
      Fehlermeldung, dass keine Verbindung zur Datenbank hergestellt werden kann.

      Schon x-Mal deinstalliert und wieder neuinstalliert, aber nichts geht weiter.

      Ich habe jetzt den Verdacht, dass sich PostGre gar nicht installiert hat und sich
      deshalb auch keine Verbindung zum Datenserver herstellen lässt.

      Also habe ich versucht über das Unterverzeichnis des Elephant "PostGre" zu
      installieren, wie es von PS.de empfohlen wird:
      " Achtung: Eine lauffähige PostgreSQL-Installationsdatei findest du direkt im Programmverzeichnis des Elephants auf deiner Festplatte. Die Datei heißt postgresql-8.3-int.msi. Bitte benutze diese Datei, da die offizielle Download- Version aus dem Internet bei vielen Leuten zu Problemen geführt hat.

      Wenn ich die Installation aber abschließen will, dann verlangt das Programm,
      dass ich einen Nutzername bzw. ein Passwort eingeben soll, damit eine
      Verbindung zum Server hergestellt werden kann.

      Meine Fragen lauten also:

      1. Welchen Nutzername (Name des PC´s ???) und
      2. welches Passwort muss man da denn eingeben?


      Für eure Hilfe wäre ich echt dankbar!!!!!!!
  • 5 Antworten
    • xHexerx
      xHexerx
      Bronze
      Dabei seit: 22.02.2008 Beiträge: 294
      Und weiter gehts...

      Mittlerweile habe ich PostGreSQL aus dem Unterverzeichnis des Elephant mehrmals
      installiert (und immer wieder deinstalliert auch über cmd), indem ich:

      postgre als Nutzername sowohl für das Benutzerkonto am Server als auch als internen
      Nutznername verwendet habe (natürlich mit verschiedenen Passwords).

      Danach den Rechner neu gestartet, dann Systemsteuerung/Verwaltung/Dienste
      den Dienst Postgre 8.3 auf der Liste gefunden (wird als gestartet angezeigt),
      trotzdem nochmal starten lassen.

      Danach vom Desktop aus den Elephant (als Admin) gestartet und wieder die
      Fehlermeldung "Keine Verbindung zur Datenbank...." bekommen.

      Ich dreh noch durch. :s_cry:

      Beim deinstallieren habe ich über die Start/Suchfunktion "postgre" eingegeben und erst
      dann einen Neustart gemacht, wenn kein Eintrag mehr gefunden wurde.

      Ach ja. Ich komme nicht in das Verzeichnis: Dokumente und Einstellungen rein,
      da heisst es immer: Zugriff verweigert (obwohl Administrator).

      Sollte das das Problem sein und wenn ja, wie kann man den Zugriff erlangen.

      Wäre echt super, wenn jemand eine Lösung für diese Probleme wüsste (und sie hier
      reinscheibt)...
    • xHexerx
      xHexerx
      Bronze
      Dabei seit: 22.02.2008 Beiträge: 294
      Werde allmählich zum Selbstunterhalter...

      Also. Nach Recherchen in verschiedenen Foren habe ich die Information, dass es bei dem
      Betriebsprogramm "Vista" das Verzeichnis "c: Dokumente und Einstellungen" eigentlich
      gar nicht mehr gibt, sondern nur noch als rudimentäres Verzeichnis aufgeführt wird (für Downgrades zu XP).

      Wenn das stimmt, dann kann man natürlich unter Vista keinen Zugriff darauf erlangen
      und somit die Dateien darin auch nicht löschen (Verzeichnis ist ohnehin leer).

      Wenn dem so ist, warum steht dann in der Deinstallationsanleitung hier bei PS.de
      für Vista, dass man das Verzeichnis aufrufen und PostGre komplett löschen soll???
    • Ajezz
      Ajezz
      Black
      Dabei seit: 19.07.2005 Beiträge: 10.245
      Bist du sicher, daß es an PostgreSQL liegt?

      So wie sich das für mich liest, hast du eine völlig lauffähige SQL-Installation, aber vermutlich im Elefanten einfach falsche Verbindungsdaten angegeben.

      Schon mal überprüft?
    • xHexerx
      xHexerx
      Bronze
      Dabei seit: 22.02.2008 Beiträge: 294
      Kann gut sein, weil ich mich überhaupt nicht auskenne.... :facepalm:

      Vielleicht kannst Du mir eine kurze Anleitung geben, wo ich die Verbindungsdaten
      einsehen kann, wie sie eingestellt sein müssen und wie ich die Daten ändern kann,
      falls sie falsch sind.

      Das wäre echt super!
    • Ajezz
      Ajezz
      Black
      Dabei seit: 19.07.2005 Beiträge: 10.245
      Ja gut, wie du es halt installierst. Server localhost, Port wohl 5432. Nutzername schreibst du oben, ist postgre. Und halt das Paßwort dazu. Im Elefant selber kenne ich mich nicht aus, aber irgendwo wird es da schon eine Option zur DB-Verbindung geben.

      Schau dir im Zweifel auch mal die SQL-Posts aus dem Sticky oben durch, insbesondere die Einführung von netsrak.