[DONE] neue db...passwort vergessen

    • HRvBoedefeld
      HRvBoedefeld
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 728
      hab gerade meine alte 0.64-version deinatalliert und die 0.84 installiert.
      hat alles super geklappt.

      nun erscheint allerdings die meldung:

      "bitte legen sie zunächst eine neue datenbank...."

      die datenbank weiß ich noch, war elephantdb

      allerdings kommt ncah meinen versuchen mit dem passwort ständig "FATAL ERROr 28000 password authentification failed blabla..."

      kann ich mir irgendwo n neues pw zuschicken lassen oder wie läuft das ganze




      thx
  • 33 Antworten
    • aLFie
      aLFie
      Bronze
      Dabei seit: 20.07.2006 Beiträge: 315
      Hi simonroll,

      es gibt ein Verzeichnis auf deiner Festplatte das nennt sich: C:\Program Files (x86)\PostgreSQL\8.3\data oder so ähnlich.

      Dort findest du eine Datei, die heißt "pg_hba.conf" und öffnest sie mit dem Notepad oder einem anderen Texteditor. (Rechtsklick, Öffnen mit...)

      Dort findest du unter der eingerückten Spalte "Method" im Moment noch die Eigenschaft "md5". Diese änderst du nun auf "trust" (für dich ist denke ich nur IPv4 relevant) und sieht dann wiefolgt aus:

      code:
      # TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD
      # IPv4 local connections:
      host    all         all         127.0.0.1/32          trust
      


      Speichere die Datei und versuche nochmal alles zu starten.

      VG
    • HRvBoedefeld
      HRvBoedefeld
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 728
      also erstmal danke


      hab gefunden und das md5 in trust geändert
      (nur die zeile oder die zeile darutner von IPv6 auch?)

      jedenfalls kommtne fehrlermeldung..der zugriff auf C:\Program Files (x86)\PostgreSQL...... wurde verwehrt....
      ich denk ich hab keine erlaubnis darin rumzuschreiben...

      wie kann ich das umgehen bzw. was muss ich um- oder ausstellen?

      thx
    • aLFie
      aLFie
      Bronze
      Dabei seit: 20.07.2006 Beiträge: 315
      Hi,

      IPv6 brauchst du in deinem Fall denke ich nicht.

      Zur Sicherheit, beende mal den Dienst von PostgreSQL. Das kannst du über "Start >> Alle Programme >> PostgreSQL >> Stop Service"

      Danach schaust du nochmal in das Verzeichnis in der die "pg_hba.conf" liegt ,schaue in die Eigenschaften über "Rechtsklick auf die Datei >> Eigenschaften" und prüfe ob ein Schreibschutz aktiv ist "Attribute: [X] Schreibgeschützt".

      Wenn dort ein Häkchen ist, dann entfernst du diesen und klickst auf "Übernehmen".

      Wenn es dann noch immer nicht klappt, meld dich einfach nochmal.

      VG
    • RaiserBlade
      RaiserBlade
      Bronze
      Dabei seit: 17.10.2007 Beiträge: 5.759
      Original von aLFie
      Hi simonroll,

      es gibt ein Verzeichnis auf deiner Festplatte das nennt sich: C:\Program Files (x86)\PostgreSQL\8.3\data oder so ähnlich.


      VG
      Hey,

      ich hab 8.3 und 8.4. Welchen ordner nehm ich da?
    • aLFie
      aLFie
      Bronze
      Dabei seit: 20.07.2006 Beiträge: 315
      Dafür müsstest du wissen, welche Version des PostgreSQL dein Elephant benutzt.
    • HRvBoedefeld
      HRvBoedefeld
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 728
      aaaaahh

      hab das ding jetz von md5 in trust geändert!

      als passwort hab ich jetzt einfach passdb eingegeben, was ja eig. eh egal sein sollte.


      jedenfalls erscheint nun folende meldung:

      "von der übertragungsverbindung können keine daten gelesen werden: eine vorhandene Verbindung ´wurde vom remotehost geschlossen"

      whats my line?


      sorry dass ich hier so rumnerv, aber irgendwas scheint bei mir hier nich zu stimmen... :(
    • Hergen13
      Hergen13
      Bronze
      Dabei seit: 05.08.2008 Beiträge: 1.271
      postgre-server wieder starten?!
    • HRvBoedefeld
      HRvBoedefeld
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 728
      thx. (hab start service betätigt, ahtte ich tatsächlich vergessen )

      aber neue fehlermeldung
      "..role elephantdb doesnt exist .."

      ????

      bin mir eig ziemlich siche rdass das immer so hieß..
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hey,

      jetzt wirds "kompliziert".

      Installier dir mal pgadmin http://www.pgadmin.org/ und verbinde dich damit zum Datenbankdienst. Dort siehst du dann auch wie deine Datenbank heißt.
    • Kuzi11
      Kuzi11
      Bronze
      Dabei seit: 06.11.2007 Beiträge: 1.313
      Hab da auch mal ne Frage dazu.
      Hab das gleiche Problem wie OP. Habe das wie oben beschrieben geändert und jetzt sagt er mir, dass die "role" nicht existiert.
      Hatte früher den Elephanten auf nem anderen Rechner installiert. Und wissen, wie ic meine Datenbank da benannt habe, tu ich auch nicht mehr.
      Gibt es nicht irgendeinen einfachen Weg, um so eine Datenbank zu erstellen???

      Jetzt wird mir diese Meldung angezeigt: Von der Übertragungsverbindung können keine Daten gelesen werden: Eine vorhandene Verbindung wurde vom Remotehost geschlossen.
    • Kuzi11
      Kuzi11
      Bronze
      Dabei seit: 06.11.2007 Beiträge: 1.313
      Original von mrk1988
      Hey,

      jetzt wirds "kompliziert".

      Installier dir mal pgadmin http://www.pgadmin.org/ und verbinde dich damit zum Datenbankdienst. Dort siehst du dann auch wie deine Datenbank heißt.
      Was muss man sich denn da runterladen? Finde da nämlich leider keinen Link.
      Kann jemand den Link bitte posten? Besten Dank.
    • MichaelWagner42
      MichaelWagner42
      Bronze
      Dabei seit: 12.09.2009 Beiträge: 1.552
      Guten Abend,

      Ein Downloadlink wäre dieser hier: http://wwwmaster.postgresql.org/redir/53/h/pgadmin3/release/v1.8.4/win32/pgadmin3-1.8.4.zip

      Ciao
      Michael
    • Kuzi11
      Kuzi11
      Bronze
      Dabei seit: 06.11.2007 Beiträge: 1.313
      Besten Dank. Hat super geklappt.
    • HRvBoedefeld
      HRvBoedefeld
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 728
      Datenbank wurde übernommen!!!

      aber dann wurde es ganz komisch... ich minimier elephant und fang an zu spielen da erscheint plötzlich nochmal das fenster mit "entwerfen sie erst eine neue datenbank blabla..."

      zudem erscheint kein HUD o.ä.

      ???
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Das sollte nun nicht mehr passieren. Existiert denn deine Datenbank jetzt noch? Was passiert wenn du das Fenster einfach schließt, ohne eine Datenbank anzulegen? Hast du dann versucht noch eine neue anzulegen?
    • HRvBoedefeld
      HRvBoedefeld
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 728
      ich hab einmal okay geklickt, was wohl dazu geführt hat, dass ich nochmal eine angelegt hab.

      anschl. hab ich einfach auf abbrechen geklickt wenns hochgepoppt is und bin dann in die elphant startseite gelangt....
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Seltsam... aber ansonsten funktioniert alles?
    • HRvBoedefeld
      HRvBoedefeld
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 728
      nöö leider nich, es erscheint beim spielen kein HUD....
      woran könnte das liegen?
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Das könnte jetzt daran liegen, dass deine Portaleinstellungen unvollständig sind, oder der Elephant ein anderes Problem hat. Erhältst du eine Fehlermeldung wenn du den Elephant beendest? Was sagt dein Logfile?

      Das Logfile findest du unter XP hier:

      "C:/Dokumente und Einstellungen/<Benutzername für Windows>/Eigene Dateien/PokerStrategy.com/PokerStrategy.com Elephant/Logs"

      Unter Vista/Win 7 hier:

      "C:/Users/<Benutzername für Windows>/Dokumente/PokerStrategy.com/PokerStrategy.com Elephant/Logs"
    • 1
    • 2