Database initialisation failed

    • GeorgeGamble
      GeorgeGamble
      Bronze
      Dabei seit: 13.06.2009 Beiträge: 268
      Hallo lieber Pokerstrategen!

      Ich hoffe, ihr könnt mir bei der Installation von PostgreSQL helfen.


      Ich verwende Win7 über Bootcamp auf einem Apple iMac.
      Der Mac sollte nichts zur Sache tun, da ich bereits einmal
      eine funktionsfähige Datenbank hatte.
      Windows Defender ist deaktiviert.

      Besonderheiten bei der Installation:
      - ich wähle ein persönliches Passwort (nicht schlimm, oder?)
      - ich wähle bei "Select the locale to be used by the new
      Database cluster"
      "German, Germany"
      (Fehler tritt auch bei Wahl von "English, US" auf)
      - ich lasse den Hacken bei "Install pl/pgsql in template1 database?" stehen.

      Es taucht am Schluss diese Fehlermeldung auf:

      Die Datenbank funktioniert nicht.

      Ich deinstalliere also alles mittels unseres Foren-Guides und
      erhalte dabei folgende Fehlermeldungen:




      Im Anschluss noch einmal die Verzeichnisse gelöscht und die
      .cmd-Datei aus den Guide verwendet.

      Neustart -> Neuinstallation -> selbe Fehler.


      Das Ganze kann ziemlich an den Nerven nagen. Bei Google habe ich nichts
      gefunden und auch hier im Forum noch nicht (genau) diesen Fehler.

      Ich hoffe, jemand weiß Rat.

      Cheers,
      George
  • 6 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.240
      Versuch mal die 8.3 von http://www.postgresql.org zu laden und zu installieren.
      Wenn die auch nicht geht - die 8.2 hat bisher immer funktioniert.

      Von den Fehlermeldungen her würde ich aber sagen es hat irgendwas mit Zugriffsrechten im Dateisystem zu tun. database cluster ist das postgresql data Verzeichnis auf deiner Platte, Initialization failed heißt er kann das nicht erzeugen. Evtl. mal einen anderen Pfad versuchen? Installierst du auf C:?
    • GeorgeGamble
      GeorgeGamble
      Bronze
      Dabei seit: 13.06.2009 Beiträge: 268
      8.3 funktioniert auch nicht. Bei der Installation bekomme ich aber
      den Hinweis, dass PostgreSQL bereits auf meinem Rechner existiert:



      Dieser Pfad existiert natürlich längst nicht mehr, zumindest nicht für mich
      sichtbar (unsichtbare Ordner eingeschlossen).

      Die bedeutet aber, dass mein altes PostgreSQL nicht vollständig
      deinstalliert wurde. Wie finde ich alle Benutzerkonten(?) heraus,
      unter denen ich womöglich PostgreSQL einmal installiert habe,
      um die Reste dann mittels der .cmd-Datei wirklich zu entfernen?

      8.2 habe ich nach einigem Suchen gefunden, jedoch nie als Installations-
      Paket.

      Ja, immer auf C:, eine andere Möglichkeit habe ich auch nicht.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.240
      versuchs mal mit Revo Uninstaller bzw. direkt die Einträge in der registry löschen.
    • GeorgeGamble
      GeorgeGamble
      Bronze
      Dabei seit: 13.06.2009 Beiträge: 268
      Mhh, die Meldung, es sei bereits vorhanden, bringt er nicht mehr,
      der Fehler am Ende tritt jedoch weiterhin auf.

      Was meinst du mit Zugriffsrechten im Dateisystem denn konkret?
    • GeorgeGamble
      GeorgeGamble
      Bronze
      Dabei seit: 13.06.2009 Beiträge: 268
      Mhh, hier hatte jemand das gleiche Problem bzgl. Database initialisation,
      jedoch nicht auf SQL bezogen.

      von: http://forums11.itrc.hp.com/service/forums/questionanswer.do?admit=109447626+1279638114877+28353475&threadId=952461

      nach hier: http://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=950264&admit=109447627+1279637150922+28353475

      Zitat von dort:
      ITS WORKING.....Here are the steps

      Created local admin account called insightmgr. The password was simple and did not include any special characters, only letters and numbers(all lowercase)

      logged off and back on under this new admin account(Local only).

      installed MSDE that came with SIM using the following options:

      DISABLENETWORKPROTOCOLS=0
      REBOOT=ReallySuppress
      SAPWD="same as account created above"
      INSTANCENAME="InsightMgr5"

      Rebooted computer
      Logged back in under local account.

      Ran svrnetcn to change port number on that instance of msde to 1453.(This gets me past the "Invalid Credentials" error I mentioned in some other posts)
      Restarted SQL

      Ran typical install and put in the credentials for the local account I was logged in as.

      Changed port number and instance name to match.

      Computername\InsightMgr5
      Port: 1453

      Clicked next and watched the install... It worked fine. :-)


      Bin des Englischen mächtig, jedoch nicht dieses Fachkauderwelschs.
      Kann mir das jemand erklären?
    • GeorgeGamble
      GeorgeGamble
      Bronze
      Dabei seit: 13.06.2009 Beiträge: 268
      Hui, jetzt geht es.

      Habe den Windows Service "Secondary Logon" gestartet und danach mit einer 8.3.msi-Datei installiert. Jetzt geht es!