Keine Verbindung zur Database weil...

    • Pablo1337
      Pablo1337
      Gold
      Dabei seit: 17.11.2008 Beiträge: 3.309
      ...der Servername anscheinend nicht hin haut!???

      127.0.0.1 --> damit habe ich mich immer eingelogged und nun schreibt er mir, dass er nicht auf diesen Server verbinden konnte... what´s up here???
  • 12 Antworten
    • Pablo1337
      Pablo1337
      Gold
      Dabei seit: 17.11.2008 Beiträge: 3.309
      FICK DIESES POSTGRE...........

      Ich hab alles deinstalliert und versucht es neu zu installieren... ich habe nach Anleitung jeden Scheiß gelöscht und versuchte es vergebens neu zu installieren... Entweder er schreibt: postgres Benutzerkonto ist bereits vorhanden... Nehme ich ein anderes Benutzerkonte sagt er: Interner Fehler bei der Suche nach Benutzerkonto.... bla bla bla... What the fuck... das geht mir so derb auf den Sack!!!!!!!!!

      Edit.: Poker tiltet mich nicht mehr... nun tut es die Software!!!
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Um den Postgresql User zu löschen bitte als Administrator eine Kommandozeilenaufforderung (= Windows Befehlszeilenprozessor = DOS Box =...) aufmachen und folgendes eingeben:

      net user postgres /delete

      damit wird der Benutzer gelöscht und du kannst neu installieren.
    • Pablo1337
      Pablo1337
      Gold
      Dabei seit: 17.11.2008 Beiträge: 3.309
      Habe es so versuchte, nun sagt er mit bei der Neuinstallation:

      "Interner fehler bei der Suche nach Benutzerkonto:
      Zuordnungen von Kontonamen und Sicherheitserkennung wurden nicht durchgeführt."
    • Pablo1337
      Pablo1337
      Gold
      Dabei seit: 17.11.2008 Beiträge: 3.309
      Habe es nun mit dem 8.4 installer versucht und einfach ne neue Database angelegt... Dennoch ist es für mich unverständlich, warum auf einmal keine Verbindung mehr zur Datenbank hergestellt werden konnte - von heut auf morgen!??
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Das kann immer mal vorkommen, z.B. durch Windows Updates oder sowas.
      Normalerweise ist das mit einem Reboot behoben oder mit ein paar anderen kleinen Eingriffen.
      Aber du hast ja gleich mit Kanonen auf Spatzen geschossen....
    • MikeStone
      MikeStone
      Bronze
      Dabei seit: 15.01.2009 Beiträge: 90
      Original von netsrak
      Um den Postgresql User zu löschen bitte als Administrator eine Kommandozeilenaufforderung (= Windows Befehlszeilenprozessor = DOS Box =...) aufmachen und folgendes eingeben:

      net user postgres /delete

      damit wird der Benutzer gelöscht und du kannst neu installieren.
      Hi, du scheinst dich mit dem Thema gut aus zu kennen. ^^

      Daher jetzt mein Problem... PT2 wurde bei mir als erstes installiert und irgendwann schaffte ich es auch, SQL einzurichten, aber dann habe ich SQL deinstalliert um den HM endlich zum laufen zu kriegen. Die Folge ist, das ich die PT SQL Datenbank nicht mehr aufrufen kann, nur HM funzt. ;(

      Nun, da ich mich für PT3 interessiere, sieht er die vorhandene SQL Variante 8.4 und installiert sich kein zusätzliches SQL.

      Was soll ich machen um beide Programme zum laufen zu kriegen?

      Nachtrag: Ich sehe gerade, wenn ich in das SQL Verzeichnis gehe, das sich dort auch noch Elephant Symbole zeigen!?!
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Also grundsätzlich: du brauchst nur eine Postgresql Installation um alle 3 Programme zu betreiben, d.h. wenn du HM installiert hast und das funktioniert auf keinen Fall Postgresql nochmal installieren.

      Einfach die Datenbankverbindungsdaten vom HM (findest du im Database Management) für die anderen Programme übernehmen und jeweils eine neue Datenbank erstellen lassen.
    • MikeStone
      MikeStone
      Bronze
      Dabei seit: 15.01.2009 Beiträge: 90
      Original von netsrak
      Also grundsätzlich: du brauchst nur eine Postgresql Installation um alle 3 Programme zu betreiben, d.h. wenn du HM installiert hast und das funktioniert auf keinen Fall Postgresql nochmal installieren.

      Einfach die Datenbankverbindungsdaten vom HM (findest du im Database Management) für die anderen Programme übernehmen und jeweils eine neue Datenbank erstellen lassen.
      Wow, du bist ja der Wahnsinn! :) Geschlagene 2 Tage habe ich damit verbracht, meine Fehler zu suchen... ich hätte dich besser sofort anschreiben und mir die Zeit sparen sollen.

      Danke, danke, danke :D

      Hast du vielleicht auch eine Idee, wie ich bei PT2 den Port ändern kann, denn der steht noch auf 5434?
    • Pablo1337
      Pablo1337
      Gold
      Dabei seit: 17.11.2008 Beiträge: 3.309
      Original von netsrak
      Das kann immer mal vorkommen, z.B. durch Windows Updates oder sowas.
      Normalerweise ist das mit einem Reboot behoben oder mit ein paar anderen kleinen Eingriffen.
      Aber du hast ja gleich mit Kanonen auf Spatzen geschossen....
      Ehrlich, was anderes war auch nicht mehr möglich :)

      Ich hatte im Netz auf sämtlichen Seiten rumgesucht - selbst der Weg auf der posgresql page hatte als info mitgegeben - if nothing works-reinstalling will help 99% to fot your problems (so etwa)
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Original von MikeStone
      Wow, du bist ja der Wahnsinn! :) Geschlagene 2 Tage habe ich damit verbracht, meine Fehler zu suchen... ich hätte dich besser sofort anschreiben und mir die Zeit sparen sollen.

      Danke, danke, danke :D

      Hast du vielleicht auch eine Idee, wie ich bei PT2 den Port ändern kann, denn der steht noch auf 5434?

      Das ist schon so lange her....
      Irgendwo gibt es da auch eine Konfiguration der Datenbankverbindung und da kannst du den Port ändern. Gehen tut es auf alle Fälle, ich hatte das damals auch mal gemacht. Einfach mal die Menüs durchgehen.
    • Knochenfabrik
      Knochenfabrik
      Bronze
      Dabei seit: 09.01.2007 Beiträge: 1.263
      Original von netsrak
      Das kann immer mal vorkommen, z.B. durch Windows Updates oder sowas.
      Normalerweise ist das mit einem Reboot behoben oder mit ein paar anderen kleinen Eingriffen.
      Aber du hast ja gleich mit Kanonen auf Spatzen geschossen....

      welche kleinen eingriffe ? hab gerade das selbe problem das plötzlich die postgres datenbank nicht funktioniert.

      ok hab die scheiß postmaster.pid datei gelöscht und es funktioniert jetzt wieder. für was ist die dumme datei gut wenn postgres sih mit ihr nicht starten läßt grrrrrr
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Das ist eine Lock Datei mit der gesteuert wird das der Postgresql Dienst nicht 2* startet.

      Also wenn der Dienst starten will guckt er ob die Datei da ist. Wenn ja beendet er sich gleich wieder und wenn nein legt er sie an und startet.
      Beim Beenden löscht er sie dann wieder.

      Wenn Postgresql oder dein Rechner mal abstürzen wird die Datei nicht gelöscht und der Dienst startet erstmal nicht mehr.